Unable to login after installation

Home Forums Using MintHCM Unable to login after installation

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #2081


    I have installed minthcm as per the guide. But after installation i am unable to login minthcm.
    the error message is; (ERROR! LBL_MINT4_AUTH_LOGIN_ERROR). i go into inspect and found an error there as well. and the error is; Failed to load resource: net::ERR_TOO_MANY_REDIRECTS.

    Please guide.


    Hello Saeed!

    Could you please tell me your PHP version? It would also be helpful if you could share the contents of the legacy/install.log and legacy/minthcm.log files. Additionally, could you show me what your .htaccess file looks like?



    I have installed a setup in my localhost (window) and experiencing two issues.

    Firstly, after logging in via admin, the page is not redirecting.

    Secondly, the label text is not properly showing as per the language file. Currently, it is visible as “LBL_MINT4_AUTH_LOGIN_TITLE” etc.

    Below is the .htaccess code,

    <IfModule mod_rewrite.c>
    Options +SymLinksIfOwnerMatch
    RewriteEngine On
    RewriteBase /minthcm-4.0.2

    RewriteRule ^assets/(.*?)$ assets/$1 [L]
    RewriteRule ^legacy/(.*?)$ legacy/index.php/$1 [L]
    RewriteRule ^api/(.*?)$ api/index.php [L]
    RewriteRule ^bg.jpg$ bg.jpg [L]
    RewriteRule ^favicon.ico$ favicon.ico [L]
    RewriteRule ^Api/(.*?)$ legacy/Api/$1 [R=301,L]
    RewriteRule ^service/(.*?)$ legacy/service/$1 [L,QSA]
    RewriteRule ^index.php$ legacy/index.php [L]

    RewriteRule .* index.html [L]

    I couldn’t find any messages in the minthcm.log file.

    Can you assist me in resolving the redirection issue and labeling text?



    I have the same problem. After fresh installation I got the login-dialog with the LBL_MINT4_AUTH_LOGIN_TITLE and installation doesn’t start.

    My configuration on Debian 12.4

    Apache/2.4.57 (Debian)
    PHP 8.0.30
    loaded modules: core mod_so mod_watchdog http_core mod_log_config mod_logio mod_version mod_unixd mod_access_compat mod_alias mod_auth_basic mod_authn_core mod_authn_file mod_authz_core mod_authz_host mod_authz_user mod_autoindex mod_deflate mod_dir mod_env mod_filter mod_headers mod_mime prefork mod_negotiation mod_php mod_reqtimeout mod_rewrite mod_setenvif mod_status

    My .htaccess looks like:
    <IfModule mod_rewrite.c>
    Options +SymLinksIfOwnerMatch
    RewriteEngine On

    RewriteRule ^api/(.*?)$ install/index.php [L]

    RewriteRule ^assets/(.*?)$ assets/$1 [L]
    RewriteRule ^favicon.ico$ favicon.ico [L]
    RewriteRule ^bg.jpg$ bg.jpg [L]

    installation path /var/www/html/minthcm
    chmod 755 on all files and directories
    user and group www-data on all files and directories

    <VirtualHost *:80>
    # The ServerName directive sets the request scheme, hostname and port that
    # the server uses to identify itself. This is used when creating
    # redirection URLs. In the context of virtual hosts, the ServerName
    # specifies what hostname must appear in the request’s Host: header to
    # match this virtual host. For the default virtual host (this file) this
    # value is not decisive as it is used as a last resort host regardless.
    # However, you must set it for any further virtual host explicitly.
    #ServerName http://www.example.com

    ServerAdmin webmaster@localhost

    DocumentRoot /var/www/html/minthcm

    <Directory /var/www/html/minthcm>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted

    # Available loglevels: trace8, …, trace1, debug, info, notice, warn,
    # error, crit, alert, emerg.
    # It is also possible to configure the loglevel for particular
    # modules, e.g.
    #LogLevel info ssl:warn

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    # For most configuration files from conf-available/, which are
    # enabled or disabled at a global level, it is possible to
    # include a line for only one particular virtual host. For example the
    # following line enables the CGI configuration for this host only
    # after it has been globally disabled with “a2disconf”.
    #Include conf-available/serve-cgi-bin.conf


    Hmmmm – after testing it with Safari – this error is gone :/
    Now I am struggling with ElasticSearch configuration – it says “empty reply from server”


    Hello guys!
    Suresh, I need more information. Can you please, tell me what you see in your browser console when the problem happens? Also, check if there’s anything in the PHP error logs. This info will help us fix things faster.

    Cyberchriss, can you tell me what version of ElasticSearch you’re using?
    And please, try testing the connection with ElasticSearch using CURL and share the results.
    I’ve checked this error on Google: “ElasticSearch empty reply from server.” There’s a mention of a flag, xpack.security.enabled, that might need to be set to false. Take a look at Google too.

    Let me know about the results!


    Hi Dawid,
    Thank you for your reply. Installation issue is fixed now.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.